[APP][Pro] Misol and Ecowitt (version 0.1.10 and test 0.1.23 )

I have added a new “Simulation Data” tab in the App - Configure App section. You can copy the data from the Detect tab and past it into the Simulation data box. When the Activate button is tapped you should see a confirmation message and then the app will process the text as if it is received from the gateways. You can edit any of the the field values and tap on Activate to simulate new data.

everything works now, even test from the flow

1 Like

Thanks Adrian Rockall for this great app, works very nice to monitor the moisture levels in my garden and automate the sprinklers on it.

1 Like

BEWARE: It looks like the GW1000 firmware 1.6.8 breaks the Customised data transmission. I would advise switching off automatic updates and not updating to this version.
I have requested support for the issue and will update on here when it is fixed.

OK, it appears after resetting the GW1000 to factory default and setting it up again fixed the problem.

Will you add support for the Ecowitt Wittboy all-in-one weather station when it comes out?
Looking at the price this thing is much more interesting than an Weatherflow Tempest, but this one is already supported in Homey.

It looks like a nice unit.
If it has a similar access method to the current GW1000 and GW1100 then I will try, but someone might need to buy me one to test with :wink:

I am trying to connect to a miso gateway. I get data in the WS view app.

I only get the message that no new units are found when trying to add it as a unit in Homey. I have tried with both homey cloud id and ip-adress.

Is this a known issue at the moment?

The GW1000 have software version 1.6.8 and has been reset after firmware upgrade.

My gateway is on the same version and is working fine. I use Homey’s local IP address as I found it to be more reliable. I have assigned a fixed IP for Homey.
It might take a minute for the gateway to push information to Homey so it can pick up the sensors.
Is the gateway and Homey on the same sub net?
So this is my configuration:

1 Like

I forgot to reply back. It now works, i had forgotten a forwardslash :sweat:

1 Like

After a recent network crash at home I accidentally upgraded the firmware of the GW1000 gateway to 1.7.3. Now I am unable to connect to the gateway with homey. The gateway works fine in the iOS app.

Homey is set up with fixed IP and stup in the app (homey and gateway) is identical to the one that worked before the crash.

Is this i known issue?

Dear Adrian Rockall,
Thank you for the app, that’s working great with the soil moisture sensor and the gateway.
Is it planned to include the WH55 Wireless Water Leak Detection Sensor or the WN30 temperature sensor?

Could you go to Homey Developer Tools, select the Misol and Ecowitt app, then the Detected tab and click on the Send Log button. That will provide me with the information that is sent by the gateway so I can add the devices.

Thanks a lot for the really quick answer. I have just sent the logs, both devices were active in the 2nd log.

Yep, I can see the data in there so shouldn’t be a problem to them.

New version is in the store under the test link

Works like a charm! Fantastic support Adrian, thanks a lot!


1 Like

This is fantastic! A great way to check the soil moisture in my garden. Thank you very much, @Adrian_Rockall for this super handy app.

1 Like

First of all thanks for your great work. You were recommended by the Homey guys when I asked them which soil moisture sensor I should get. Works like a charm. What I just wanted to let you know. The configuration using WS view did NOT work (no data, no device recognized by homey). When I used the Ecowitt App and entered your mentioned data everything worked fine immediately. (both Apps were used on IOS). Maybe this might help for the future.
Thank you for your great work!

Thank you for letting me know. Interesting, as I use WSView for both the Misol GW1000 and Ecowitt GW1100A gateways. Which gateway did you get?