[APP][Pro] Kia and Hyundai

Everything is displayed correctly for me.
Kia Niro Hybrid

The second insights is from an old app version. It doesnt get updated anymore. I asked Athom how to remove those old insights, but that seems impossible unless you delete the entire car from Homey.

1 Like

I do see in your Insights graph that sometimes the odometer value seems ok. Is that on random moments, or is that e.g. always when the car is on?

Seems like everytime I park the car, it updates with the correct value and then a value of 0 5 to 30 minutes later…
But the problem seems to be bluelink, because the bluelink app is also saying odometer = 0km… I will try to contact the bluelink peoples :smiley: Thanks for your help @Gruijter

1 Like

Thanks for your reply.
I deleted the car and added it again.
Only one odometer remains :+1:

1 Like

@MatsHansen

I created a new version 2.9.4 for you that provides a workaround to the 0-odometer bug in your car.

v2.9.4

  • Ignore 0 odometer reports.
2 Likes

Wow :heart_eyes: I’ve updated and will monitor the odometer value… Thanks :blush:

1 Like

Many thx for your kind donation Mats! :beer:

Thanks for your quick response and help, every time :blush::clinking_glasses:

1 Like

@Gruijter it looks like it’s still the same “issue” with 2.9.4… :see_no_evil:

Can you send me an app diagnostics report?

aa8d1acf-47e2-452e-9bfc-283bed6f262f

new version 2.9.5 is published

First time you receive a valid odo value it should keep that. But difficult for me to test since I dont have the issue you are having.

Thanks for trying :blush: Tested, but the same result :confused: Got an answer from the Bluelink team today: “We regret to inform you that the issue regarding the odometer reading in the Bluelink app is known, and our team is doing their utmost best to find a fix to it, which is expected with the next software update.”

I get error “could not find that pair session” after providing credentials to the homey hyundai app. What to do?

Means you waited too long before pressing Next. Restart the Homet Mobile App on your phone and try again. I think you need to press Next within 30 seconds or so.

Thanx for your answer. Tried that but didnt work. But the issue was resolved by pushing refresh in bluelink. Think the car was in a deep sleep…

1 Like