[APP][Pro] Kia and Hyundai

Tested v2.9.3 with the “Fix charger off” setting, and it worked well.
It stopped directly when I sent the stop command and it started when I sent the start command later during the night.

I’m a bit curious your use case because I never succeded in stopping the charging with the version that didn’t´have this fix.

Note that I never poll the car, instead I use an energy meter connected to my wall box to notify home that charging has started.

1 Like

I mostly start/stop charging with a smart plug, and not by commanding the car itself.

Im starting lately to get these in the log alot. Using 2.9.3

[err] 2022-10-16 06:29:56 [uvo] [dev] doPoll failed @EuropeVehicle.fullStatus: [401] Unauthorized on [GET] https://prd.eu-ccapi.kia.com:8080/api/v2/spa/vehicles/8d301127-9bc9-4bc4-8b95-5717c76b7154/status/latest - {“retCode”:“F”,“resCode”:“4017”,“resMsg”:“Invalid request value - Invalid Application Id. - -164924277805.839”,“msgId”:"32b91a37-e057-44ad-a533-67fb443be674

I have them once a day. How often do you get them?

Well it happens more or less once a day per car but there is more to this that happens after it. That duplicate message comes everytime after it.

[err] 2022-10-16 07:41:35 [uvo] [dev] doPoll failed @EuropeVehicle.fullStatus: [400] Bad Request on [GET] https://prd.eu-ccapi.kia.com:8080/api/v2/spa/vehicles/6b984d78-a7d2-4bdd-b35b-078958a7fd85/status - {“retCode”:“F”,“resCode”:“4004”,“resMsg”:“Duplicate request - Duplicate request”,“msgId”:“bb24d1f5-ad7a-4cb7-b94d-778386fbf3a0”}
[log] 2022-10-16 07:39:38 [uvo] [dev] Status refresh from car
[log] 2022-10-16 07:39:08 [uvo] [dev] doPoll failed. Retrying in 30 seconds
[log] 2022-10-16 07:37:11 [uvo] [dev] Status refresh from car
[log] 2022-10-16 07:37:11 [uvo] [dev] Forcing status refresh via app
[log] 2022-10-16 07:29:56 [uvo] [dev] Server info changed. 20221016071504 20221016071532
[log] 2022-10-16 07:15:22 [uvo] [dev] charging off via charger off state fix
[log] 2022-10-16 07:14:58 [uvo] [dev] Status refresh from car
[log] 2022-10-16 07:14:58 [uvo] [dev] Forcing status refresh via app
[err] 2022-10-16 06:29:56 [uvo] [dev] doPoll failed @EuropeVehicle.fullStatus: [401] Unauthorized on [GET] https://prd.eu-ccapi.kia.com:8080/api/v2/spa/vehicles/8d301127-9bc9-4bc4-8b95-5717c76b7154/status/latest - {“retCode”:“F”,“resCode”:“4017”,“resMsg”:“Invalid request value - Invalid Application Id. - -164924277805.839”,“msgId”:“32b91a37-e057-44ad-a533-67fb443be674”}

More to the above.

If i turn off the app in homey and just let kias own app to be used it is no problems. As soon as i turn on the app in homey after a while this starts happening it seam to lock itself. The result in kias own app is it just spin and spin on update as a result. Untill i reset the car.

The daily error is just caused by the login validity ending. They are exactly 24hrs apart from each other. The Homey app will automatically login again and retry the command that failed. So that is normal behavior.

This might be your real problem that causes the lockups and following errors. To solve it go to advanced settings and disable ‘fix charger off after refresh’.

I had the same issue with my car. It is caused by unstable firmware of the car unit. In the shop they upgraded the firmware and that also helped.

Seam to have solved it. Will see the comming days. Thx Robin :slight_smile:


I have created an advanced flow that activates and deactivates the charging when the price is respectively below and above a certain price I have decided.
My problem is that the charging will not start again once it has been stopped. I get a message that the charger is not plugged in.
Have been looking for where I can disable “fix charger off after refresh”, as I suspect that this may well be the cause.
Actually, I would like the charging to pause and not stop completely.

In my flow, I use the following flow cards:

  1. Force status refresh (once)
  2. Turn charging on
  3. Turn charging off

After Force status refresh I wait 30 secs. before the next action.
Hoping that some of you might have some good ideas or advice

That is weird. That is not coming from the app, because I do not check if it is connected when giving the charge command.

What happens if you start , stop and start charging from the official Kia/Hyundai app? Do you get the same error?

That was a super good question. I just tested it and I get the same error via the kia app. It says on the app that “Charging: Not plugged in”, but I have not removed the charging cable.
I use the e.on charging stand, could that be the problem?

By the way, thanks for the quick reply, and also a great app for Homey :slight_smile:

1 Like

Yes, maybe or even likely.

Hi. Seems like odometer returning 0 on every update after the newest release. Hyundai Kona in my case. Any known issue with the odometer? :blush:

Odometer will be correct again after a car refresh from Homey.

Doesn’t seem to help :confused:

Can you send an app diagnostics report?

Here you go :blush: 2da65003-6b4c-4cdb-8c54-80bd05ad5c9f

1 Like

I can see that your car is actually reporting 0 for the odometer. So nothing I can do for you.

You could try resetting the car unit (pinhole button next to the volume). Or get a firmware update.

Hmm. Strange, just updated the car, so that may be the issue… Will try to reset it, thanks for your help :blush:

From insights it looks like there is 2 odometer values, and that it both reports actual and also 0 :thinking:

I can also see two Odometer values, as well as 2 Range values and 2 Speed values on my Kia.
The second one is showing the correct values. How’s that possible?

By the way, last Saturday I’ve updated the car software as well…