[APP][Pro] Heatit Controls app [v3.4.0]

@HeatitControlsAB I opened an issue on the Git repository the other day and now it seems that the repository is removed from Git, why?
Anyway I have the same issue as previously mentioned by @Automansion and Espen_Werner where there is no temperature from the temp sensor and the food sensor does not react when there is water on the sensor.

I have found a workaround to get heatit thermostats with firmware 1.92 to include with some help from some great people at homey community slack. You have to download a app from Homey Community Store

The problem is with the inclusion with unsecure device on homey… After installation of the community app and Unz-cure from the link. You should select unz-cure when you add the thermostat it will be included like it should. Dont forget to have heatit app also installed so it will find the device tru that.

Hi - two of my ZTRM3s are showing negative floor temperature - is there anything that can be done to fix this?


Hello, We are working on support for Homey Bridge. You can download the test version for Homey bridge here: Heatit Controls | Homey
TRM3 is supported on Homey Pro and will be supported on Homey Bridge.

1 Like

@HeatitControlsAB I still cant see the temperature on the sensors on with the z-relay unit. Is there a stus on a fix for this?

I got my Z-Relay working with some help from Heatit support.
Temp input 1, energy and power works, but still no voltage or current.

I had to re-add my Z-Relay without S2 (Use 00000 as PIN) and tell told me to change my group association to 1.1 on group 1 and leave the rest blank. BUT, it worked with just leaving every setting as is.
Just enable the input 1 sensor, and it worked.

1 Like

I have a Z-TRM3 that I’m unable to add to Homey at all. I was able to add it once. But tried to remove and re-add it after it was having 60% TX error rate, now it won’t pair at all. Even as the sole Z-wave device and having the Homey 2cm away from the thermostat.

Have you tried to completely cut the power, or done a factory reset? That helped me a couple of times.

Tried cutting the power yeah. Do you mean a factory reset of the thermostat or Homey? I also tried a reset of te Z-wave network to no avail.

Edit: Did a factor reset of the thermostat. Was able to add it again. Thanks. :slight_smile:

Hellow. I hav your smart smoe detectors. They work fine, but report wrong temp. Can ypou make a software solution to calibrate them? Should be an easy fix.

@HeatitControlsAB
I´m having trouble adding the z-push 8 to homey. I´m getting an error-message saying that the app is not compatible. I´m guessing this is software related. Is there a quickfix? Are you aware of this and are you planning a bug-fix?

Hello @HeatitControlsAB ,
I purchased 4x Heatit ZM thermostats and to my surprise i can’t pair them with homey. - there is no support for it. Can this be added to the Heat-it app?

I have the same problem. Installed 5 thermostats, and now 2 weeks later, 2 of them cant be reached. Tried disconnecting power and restarting app/Homey. It just wont work.
Mine showed voltages and current, but now they are both just stuck.
Locked up with around 1 day between them.

Did anybody find out what needs to be done, or why this happens?

In my experience, when this happens it does indeed not help to cycle power or restart Homey. The only way is to remove the device from Homey, factory reset the Heatit hardware, and add it back from scratch. Then you of course have to edit all your flows containg the device you removed, since it is now a “new” device. This hassle makes the hardware rather useless to me, given that the Z-Relay fails repeatedly in this way within 2-5 days or so after a reset.

We need a proper answer from Heatit. If the answer is to upgrade the devices, that’s another problem, as that would seem to require buying the costly Heatit bridge.

There was a suggestion to use an app to add the devices in a lower security mode, might be worth trying: [APP][Pro] Heatit Controls app [v3.0.2] - #158 by Peter_Johansson

And this suggestion, I haven’t tried that either yet: [APP][Pro] Heatit Controls app [v3.0.2] - #162 by Hammervoll

Though I don’t feel happy about reducing security on high power devices, I haven’t yet looked into how much security would be reduced.

1 Like

Hi,

Where can I download the zip file of this app?

It is nowhere to be found on github

Hello,

We received some unofficial code from Homey and was asked to not have the code public.

Sorry for the inconvenience.

Hello,

From what we have experienced it is devices included with security losing connection after a while.
Including devices without security seems to solve the problem.

Start by removing the device from Homey.
Reset the device to factory defaults.
Include the device to Homey and use code “0 0 0 0 0” when asked for DSK code.

The problem only appears on Homey gateways. We do not think this is something that requires a OTA update.
OTA updates can be done from any gateway that supports it or with most Z-Wave USB sticks.

Hey @HeatitControlsAB

Got a new wall controller and the battery status is not reported.
Device is unsecure already added to the Zwave network.

suggestions?

I’ve got a heatit 25a relay on Homey Bridge that disconnected after two days. It’s running on firmware received from Heatit just a month ago so up to date.

I have the same device on Futurehome and it’s stable, so suspect it’s either the homey bridge or the new heatit beta software for bridge.

It was included with 00000 as the security code.

For info only. Will try a restart when I’m at that location in a couple days.

I reset the relay and added it again on Thursday. On Saturday i lost contact with it again. It was added with 00000 as the PIN.

Error Message is the same - below. Anyone know what the issue is?