[APP][Pro] Heatit Controls app [v3.1.0]

Hellow. I hav your smart smoe detectors. They work fine, but report wrong temp. Can ypou make a software solution to calibrate them? Should be an easy fix.

@HeatitControlsAB
I´m having trouble adding the z-push 8 to homey. I´m getting an error-message saying that the app is not compatible. I´m guessing this is software related. Is there a quickfix? Are you aware of this and are you planning a bug-fix?

Hello @HeatitControlsAB ,
I purchased 4x Heatit ZM thermostats and to my surprise i can’t pair them with homey. - there is no support for it. Can this be added to the Heat-it app?

I have the same problem. Installed 5 thermostats, and now 2 weeks later, 2 of them cant be reached. Tried disconnecting power and restarting app/Homey. It just wont work.
Mine showed voltages and current, but now they are both just stuck.
Locked up with around 1 day between them.

Did anybody find out what needs to be done, or why this happens?

In my experience, when this happens it does indeed not help to cycle power or restart Homey. The only way is to remove the device from Homey, factory reset the Heatit hardware, and add it back from scratch. Then you of course have to edit all your flows containg the device you removed, since it is now a “new” device. This hassle makes the hardware rather useless to me, given that the Z-Relay fails repeatedly in this way within 2-5 days or so after a reset.

We need a proper answer from Heatit. If the answer is to upgrade the devices, that’s another problem, as that would seem to require buying the costly Heatit bridge.

There was a suggestion to use an app to add the devices in a lower security mode, might be worth trying: [APP][Pro] Heatit Controls app [v3.0.2] - #158 by Peter_Johansson

And this suggestion, I haven’t tried that either yet: [APP][Pro] Heatit Controls app [v3.0.2] - #162 by Hammervoll

Though I don’t feel happy about reducing security on high power devices, I haven’t yet looked into how much security would be reduced.

1 Like

Hi,

Where can I download the zip file of this app?

It is nowhere to be found on github

Hello,

We received some unofficial code from Homey and was asked to not have the code public.

Sorry for the inconvenience.

Hello,

From what we have experienced it is devices included with security losing connection after a while.
Including devices without security seems to solve the problem.

Start by removing the device from Homey.
Reset the device to factory defaults.
Include the device to Homey and use code “0 0 0 0 0” when asked for DSK code.

The problem only appears on Homey gateways. We do not think this is something that requires a OTA update.
OTA updates can be done from any gateway that supports it or with most Z-Wave USB sticks.

Hey @HeatitControlsAB

Got a new wall controller and the battery status is not reported.
Device is unsecure already added to the Zwave network.

suggestions?

I’ve got a heatit 25a relay on Homey Bridge that disconnected after two days. It’s running on firmware received from Heatit just a month ago so up to date.

I have the same device on Futurehome and it’s stable, so suspect it’s either the homey bridge or the new heatit beta software for bridge.

It was included with 00000 as the security code.

For info only. Will try a restart when I’m at that location in a couple days.

I reset the relay and added it again on Thursday. On Saturday i lost contact with it again. It was added with 00000 as the PIN.

Error Message is the same - below. Anyone know what the issue is?

And this morning it started working again. Hopefully the issue was resolved and it’s not just unstable.

Update:

And back not working. I’m seeing at pattern that it stops working when the homey bridge goes offline (which happens very frequently) and the time it started working was right after the same.

I found this topic when looking for a solution with my TRM3 losing its connection to Homey.
And it is a pain in the ass to reconnect it every time - I will try the insecure option that I read about here using the 00000 code.

One more question: this connecting seems to only work with Homey being next to the device. But then I bring back my Homey to its position two floors below the TRM3. While there is a repeater in between and I would love the TRM3 to connect through the repeater. When I then bring back the Homey to its position, the TRM3 continues to connect directly to the homey and not using the repeater. Any way to change that?

I have a question about the z-push 8 button.
I used to select the option to start a scene, and then select pressed once and the button number.

But with my new homey i cant figure out how to use it anymore.

Does anyone know how to use each button to start a flow.
I use the option pictured below, but it doesn’t start anything.

Hi. Do you plan to add support for WiFi thermostat? Hope you can do this soon.


Factory reset the device. start the ad device process from the heatit app.
get err in the display on the thermostat. and no green tag on stage 2 in the above picture in the app

Regarding the Push Button panels; Are they the same as several other brands?
I’ve seen them as Hewitt, Namron, Unilamp, FutureHome etc. but they all look identical.

Is there a difference?