[APP][Pro] Harmony Hub (v2.0.7)

I was told by Logitec that they have ceased manufacturing the Harmony Hub product. Mine has a hardware fault and I cannot get a replacement even though it is still under guarantee.

Anyone know of good alternative products that are supported by Homey?

1 Like

Since a few days Harmony Hub is switching a KaKu switch on and off, as soon as a Harmony activity has started. Anyone any experience with this? How could I fix this? The Harmony hub has no Kaku devices setup, so there should be no link between Harmony Hub and Kaku.

I’ve added some more activities to my Harmony Hub. How do i get them to appear on my Homey - Harmony App. Tried restarting the app.

Hi @rkokkelk,
I was wondering whether you already found some time to look into the app, understanding why it is not able to find the hub anymore.
Today, I had to reinstall the app and devices on my Homey and now found out that there’s a issue in the discovery. ‘Unfortunately’ I’m not the only one with the issue, but since this app is part of my daily routines, I’m quite bummed out given this situation.
Would really appreciate your help!
Cheers

I have a strange button issue…

When i press on the harmony remote a specific button it works fine.
But when i use a flow card to press the same button then the device respond but with a different command…

I used the Harmony app to check (and reset) the original button but everything keeps the same, so on the harmony remote itself it works fine, but when i choose the button from the flow cards in Homey an other function is started… As far as i can tell this only happens on 1 specific button but an important button (home)

Hi,

I’ve also seen multiple issue with the Harmony app. I’ve just got a new Homey Pro and I was kinda hoping that I could reproduce the issues in my own setup. Unfortunately everything works as expected at my own setup.

Debugging this issue and eventually fixing this is really difficult if I have to rely solely on diagnostic reports from Athom, which only contains a limit amount of logs, is quite difficult. That’s the reason why I have not made a sincere effort into fixing this issue.

My best bet is to currently expand the logging information that is generated by the app to increase the available information and then get some diagnostic report which might show some indicator of what the origin is of this bug.

Due to these bugs I can’t really say when I can fix this.

The activities should automatically load when you use the (start/stop) action card in Homey. First you have to select the appropriate Harmony hub and then in activities it should list all activities on your hub.

If not, please feel free to make an issue on Github:

1 Like

Okay I’ve noticed that the NPM module used by Harmony hub for websocket was quite outdated. Maybe this caused issues with the improved npm versions in the new Homey versions. So I’ve upgraded to the latest version and hoping that this might solve the aforementioned issues.

If anyone wants to test, feel free to use the following link:

Please note that this at best an educated guess; there is no guarantee this actually fixes the issues.

Hi,
What is the logic behind the action “Hub inactive for…”?
Does it count when I for example change the channel?

Hi. Thanks for the app. Quick question. Alle devices and activities are shown with an exclamation mark every 30 seconds. Then they change back after a few seconds. The hub shows no errors and is responding fine. When no exclamation mark is shown, it works fine. Any idea how to solve this? Since this makes it a 50/50 chance that a change is not seen by Homey. Thanks!

From my experience the ! Mark means the Hatmony Hub has lost wifi connection. So Harmony still works with the remote, just not with Homey. So I’m pretty sure this is a Harmony issue but I have no idea why it does this. I have had this issue my self lately although it is OK right now.

do you have a mesh network?, in my experience the harmony hub’s network connection is unstable with some mesh networks.

Yes. These days a mesh network is the standard. :slight_smile:

Hello,
Instead of using IFTTT, I would like to connect directly my Homey to my Harmony Hub.
Fortunately, there is a Homey app for that.
Unfortunately, it says that it don’t find my Harmony Hub.
I saw that Homey and the Harmony Hub were not on the same wifi network.
So I made sure to have Homey, the Harmony Hub and the iOS device that I use with the Homey app on the same wifi network. It still doesn’t work.
I turned off 5 ghz wifi and both IP adresses are in the same subnet.
Any idea ?
Your help will be appreciated.
Thanks
Chris

@rkokkelk
Hi.
I was wondering if there is a way to change a devices on/off state without actually turning on or off?
I would like to update the devices power state based on power consumption from a smart plug to avoid the wrong power state when someone (the lady of the house) uses the original remote.

Yes! thank you for the hint! I too had these issues, I tried everything; turn homey on and off (wait 10 minutes), turn Harmony hub off, restarted the app…all resulted in the red exclamation mark. Now when I shut down 1 of my 2 mesh discs, I can see homey jump to the other disc and harmony works fine again… interesting. Hope some of you find this usefull.

I have a Harmony question that’s not really Homey-related but I’m hoping the dev can answer it :slight_smile:

My Hub seems to be crashing several times a day (also with the Harmony app disabled, so that’s not the cause).
I was wondering if the Hub has a log-file somewhere and if there is any way to have a look at it?

Thanks. I have a Unifi system but all AP’s are wired so no meshing there. But Im still getting very frustrated by this problem. I don’t know what the solution is. 50/50 that the hub is offline for Homey but online in it’s own app. A lot of flows are connected to the Harmony Hub so this is very frustrating. Anyone else a suggestion?

You need to verify if the homey and harmony are connected to the same AP, regardless if the AP’s are wired or not. Yes I understand it beats the purpose of a mesh network, but I am geussing that Harmony Hub is not completely Mesh aware, if I may call it like that. So as long as Harmony and Homey using the same AP, I bet you will not see a red exclamation mark.

That might sound as a good idea but they are both too far from each others AP’s. I have a brand new house with super isolation so I have several APs. Homey is connected to the AP in the technical area, while Harmony is connected to the AP in the living room. I can’t connect them to the same AP unfortunately.