[APP][Pro] < group > (2.5.3 - Stable)

I know I’m not being asked but I confirm I saw my blind covering groups in 2.5.3 and also latest test version - at least there was no ! sign :wink: Not sure if you will find confirmation in the debug log I sent you yesterday also not sure it helps with the case of Restrospected

1 Like

In my case @Jamie was right: my group is actually configured as “other”

I tried to find the settings to change the devices in an existing group. App says: go to homey setting page and than more–> settings → group.

But the more section doesn’t exist and going from the main settings page to settings and looking in the apps section the app is not in the list.

Am I overlooking something?


Also need to add ‘other’ devices as deprecated items, to allow older flows to continue working.


I tried to remove a device from an existing group today. The group app says: “Error: group.setSettings is not a function”:

@Joost_Else Please read the previous post in the thread.

Hi Jamie

Homey 2019 v8.1.3

After a backup restore, the latest app version got downloaded.
The app config screen is missing, I can’t edit my groups now :wink: (also missing on mobile app):
Screenshot from 2023-03-18 17-28-35

Also, my Sensors group devices are unavailable, other groups seem fine.

Thanks in advance

Hi Jamie,

Super app, thanks, keep on the good work.

I am running the Experimental version v3.0.6 on my Homey (early 2023) but our Zigbee Klemko LED driver cannot been found. In the settings of the device: “What’s plugged in?” is set on “Light” but the devicetype is “Router” and I cannot change that setting.

Could help me out on this one?


It would be really super if before posting, if people could just read one or two posts before them.

Honestly this is beyond a joke people literally asking the question answered the post prior.

I am pretty close to just flagging the posts as spam.

@Peter_Kawa please read the post prior to yours.
@Mathieu-Homey Please read the forth post before yours and which should lead you to the 6th post before yours.

Jamie can you please keep updating

instead of

…seems somehow the forum is not able to handle it properly, so we can always redirect questions/comments to your WIP message. Maybe that’s why people got confused while providing feedback…

Hi Jamie,

I’am really really sorry that you took it this way and I have red the post before me.

The problem that I was (unsuccessfully) trying to describe was that my light is not been seen as a light and not listed when I try to add those to the group. I wouldn’t imagine that “blending” could be the same thing but it is great that it is listed to solve already.

Thank you.

Like the post I mentioned, it’s likely it was added as an “other device”, rather then a light. And I have not written the “other” driver yet.

Sorry m8, I was tired, I wasn’t busy to be stupid and ignorant. The restored backup downloaded the wrong app version obviously, but I didn’t realize at that time.
But hey, make my day and flag my post as spam. I love it.
I’d better look for an other solution for your app which I honestly really liked.

All good @Peter_Kawa , its normally ok, but at times can become overwhelming and frustrating when it is happening multiple times a day.

Just want to make sure that you are aware that most of the app settings have now been moved into the device settings screen? The only feature ‘missing’ is the ability to add and remove devices from a group.

Let us all know if you find another app, perhaps it might solve other people who use the group apps use cases better as well. Virtual devices might be an option.

For everyone else I have done some work on the group settings, giving more control to advance users, ideally 99.9% of people should never have to touch these defaults.

Group Update Delay (Debounce)
The number of milliseconds to wait before updating this group with changes made to devices. A higher number will stop the groups values from ‘flickering’ but the group will take longer to be updated when a device changes it value.

Device Update Delay (Debounce)
The number of milliseconds to wait before sending a change made in this group to all the devices. A higher number will stop homey being overloaded and creating a large lag spike but devices will take longer each time they are changed by the group. The app must be restarted after changing this value for it to take effect.

Wait Between Devices
How long to wait in milliseconds between sending a command to each device in the group, sending many commands at once to Homey can cause it to get overloaded, delaying the commands can increase the reliability at the cost the the devices in a group will update at different times.
This is a work in progress and currently is not implemented

Number of Attempts
The number of times to try and change the value of a device in a group, increasing this value can increase predictability of the group at but will increase the risk that homey will timeout.

In addition, the default image for a home alarm has been changed, and the readme updated.


The new settings above are usefull when dealing with large groups. And very nice that all the settings have moved to the device advanced settings page, that’s more intuitive.

Just want to say thank you for your hard work Jamie. I’ll keep following this topic and test new versions and I am sure it will be a great ‘must have’ app when its out of beta that many people love to use.

Where can I report issues? The link to the github page on the testversion app webpage is a dead link.

So I report an issue here: when adding a new lights group in version 3.0.7 the lights in this group don’t respond when turning the group on or of etc.

Lights in groups made with earlier test version do respond.

1 Like


Hi Jamie, installed version 3.0.7 on HP running 10.0.0-rc62.

Seems both new light groups, as old light groups (created with 2.5.301) are not responding.

Steps taken;
-Add group of 2 Tradfri lights
-Group named “:paperclip:Lamp < Groep >” gets created
-Try to turn off the group
-Homey messages “Homey was unable to communicate with erkerspot while setting dim level”

-The lights individually respond just fine

If needed diagnostic ID is: 51de3530-8371-45af-af1e-fe7e2c3a765d

Hope this info helps
Keep up the good work!

Thank you for both reporting this issue, I have found the problem and fixed it, a new version will be released soon.

1 Like

New test version available

  • Fixes some older groups no longer working, thanks @Mickel_Luiten @Eric_Richters
  • Your old sensors will now work again
  • Adds the ability to create contact and motion sensors again (more coming soon).
  • Cleaner logging when submitting a a diagnostic report
  • Changed the debounce when updating capabilities to allow different capabilities to not be restricted (ie. some power values were being delayed in being updated).

Getting pretty close to feature parity with the v2 of the application, so I am looking to release to be auto updated soon. Before releasing :

  • Will finish adding different sensor types
  • Will add the ‘fused’ group
  • When showing devices, also look for sockets which have a pseudo class
  • Fix bug where it is possible to create a group with no devices.
  • Any other bugs which come up.

Lower priority is and to be released later -

  • New group type where you can select the capabilities
  • Ability to add and delete devices after a group has been created

Still on schedule to have this released before HP23 is ‘live’.



You’re welcome. New lights group works in version 3.08 and old groups remain working too.

Thank you very much!