[APP][Pro] Broadlink App

Hi @aeonax,

Hmmm. I’m stuck with this. I have my IFTTT account linked to Broadlink and when I try and create a trigger , I get to the screen Which Device - and I get Options Unavailable. I’m using the IHC app on my iPhone for RM Pro+.

Thanks, Jason

Which device are you trying to control? IFTTT limits the types of Broadlink devices mostly to on-off switches and TVs, but there is a workaround. For example, I have a “switch” called AC heating and I’ve paired it with the IR command for my air conditioner heating mode. When I switch it on via IFTTT, the IR command gets transmitted and the AC turns on.

When adding such switches, don’t use the library codes. Use the “can’t find my brand, learn remote” command. A weird thing is that this option is not available by tapping + in the upper right corner. You have to select the Broadlink device and then tap “add appliance” in the bottom. Then you get the option to add unsupported devices. 🤷

This is all provided that the IHC app is correctly paired with the IFTTT.

Good luck, I sure was pulling my hair until everything was set up, but now it works without any problems. :grin:


Firstly, I’d like to complement You for a great app! I’ve been using it successfully with a RM mini 3 for a year or two!

I was on Homey version 1.x but experienced the famous Homey upgrade freeze the night between October 30 and 31 2019. That forced me to upgrade to version 3.x and since then it seems like the recorded IR signals are lost every time Home upgrades. (…at least the two upgrades that had been rolled out since my factory reset, that is 3.1.0 and now 3.1.1)

If I go to RM mini device’s Advanced settings, I can see the previously recorded RC commands but nothing is sent If I use some of my old flows. If a try to make a new flow there are no commands to choose in the “Send Remote Command”-card.

After the upgrade to Homey 3.1.0 I discovered that if I removed the last command and recorded it again, that command alone showed up in the “Send Remote Command”-card. Therefor I recorded all the commands once more in the exact same order and gave them the exact same name, and everything worked again.

Is there a way to avoid having to record the RC-commands after a Homey-upgrade?

// Henrik

Is there a way to slow down the RF transmitting? Flashes too fast for my blinds, about 10th of a second. So quick can hardly see it lol. It’s a learnt code if that makes any difference

1 Like

Hello! I’m using this app for unlocking my doorlock wich works with RF 433Mhz. I have learned my broadlink k the commandos from the original remote, and it is working, sort of. But not as good as with the original remote.

Thing is, I need to press the button on the original remote for at least 1 second. Than it always works.

But with this app, I can not define how long the button need to be pressed.

Sending out the commando a couple of times in one flow will work, but than there is a big delay.

Does one of you have a suggestion?


I bought a broadlink rm4 mini and I’m not able to link the broadlink account with google home can anyone help

please integrate the new devices like broadlink rm4 mini :pray:

1 Like

Unfortunately I am not able to get the app to recognize my rm mini 3. Please help.

I bought the rm mini 3 because I was not able to get the IR sufficient working on my homey.
When I add the device via the app it feeds back that the device is unknown.

What I tried so far:

  • Used the setting “eenheidsmode”. This resulted into adding the RM but I was not able to learn any controls.
  • In the econtrol app from broadlink the device is also not recognized. Therefore not able to add any remotes.
  • The broadlink app does recognize my rm mini, and I can add devices and scenes. It works fine.
  • The ihc app recognizes my rm mini 3 as well, can add devices and scenes. I was able.to use this account to link more or less ok with Google home. Other accounts do not work

Econtrol app:

That will be the wrong type then. There is 2 of them u know?

2 types of what? I think I am not aware.

Update: Sorry I cant reply anymore to this topic, so I have to edit my reply :confused:

How can I recognize the “red” bean? The physical color is black. I can’t find neither of the codes you mention. Bottom shows FCC ID: 2ACDZ RMMINI3-RM.

It’s like the new red bean version instead of the black bean version.
The Red has device code 5f36, the black has 2737.
And because this Broadlink app uses the E-control app (where u cannot add the device) it’s for now not possible to add it to Homey and get it to do something.

I added two black ones Yesterday, using the old e-control app on IOS to add the Wifi config and than added them to Homey. They came with Fw. Version 5.0

Black versions have no problems to connect indeed, it’s the “Red” versions giving trouble.

How can I recognize the “red or black" bean? The physical color is black. I can’t find neither of the codes you mention. Bottom shows FCC ID: 2ACDZ RMMINI3-RM.

Bottom shows the same here on 2 different devices. For what i know: The red cannot be added to the e-control app and shows an error in the Homey app with the (5f36) code. The physical color gives no guarantee although there are actually also red colors.

Ah you are right, I received this code in the app as you mention (also visible in my screenshot).

Thanks for the quick help\responses.



I set my broadlink rm pro+ up earlier today and put it in a flow together with locative, so that the main gate would open when I got close to the house, it worked perfect and I really loved it.

So just now I was walking my dog and thought it will be cool when the gate opens up when I come walking, I checked with locative that I was outside my area, went back inside, but nothing happened…So I tried the flow in homey directly but nothing happened so I thought maybe the rm just lost connection to the gate, but when I tried its own app it worked perfect…

Anyone else experienced this?I have checked the ip and nothing has changed so I am kind of clueless as to why it cant communicate with homey

Hi All,

I’m trying to add a new RM Mini 3 to homey, it showing below error:
"Found another device: unknown (27DE)"
is this device too new not inside the database ? how request new add in or resolve the problem ?