[APP][Pro] Amazon - Alexa

Sorry, I forgot to say that. Yes, I updated to 3.5.6 immediately after you suggested it.
Your second question confuses me. I’m not able to type anything. Hitting the field named “Name of the routine” immediately triggers the unsuccessful search. Short or long pressing makes no difference. No cursor or keyboard ever show up.
If this is different for others, it may be connected to my localization, perhaps? I use a German language system. I can’t think of anything else. Can’t be a wrong installation, I guess. Same behavior since my first attempt which was three version upgrades ago.

3.4.6 of course.

Here are the screenshots:

  1. Definition of the routine I would like to trigger (Alexa app on Android)
  2. Card with the flow action before hitting the “name” field (homey app on Android)
  3. After hitting the name field (the German message in the middle means “no result”)
    Hitting the back button returns to picture 2.

Hitting the name field, only opens the search dialog. Clicking on the field at the bottom allow you to then Search.

Please look carefully at the images -


Maybe by typing the routine’s name you mean the search field in the empty results screen. Here is a screenshot. Nothing happens when I start to type something. Wanted to post this image yesterday but could not due to the forum’s restrictions (max 3 pictures).

Does the same thing occur when you attempt to alter upon the website?

(try with just one letter like “A”)

Good idea. Never tried before. As soon as I try, an orange popup appears saying “Cannot read property logger of undefined”. When I start to type in the search field, it pops up again, this time saying “filter” instead of “logger”.
I have to mention that my Echo dots have quitted to answer to other flows yesterday (“Play music” etc.). It may have to do with yesterday’s upgrade to 3.4.6. Let me install again and see if the same popup appears when the Echos are actually working.

OK, after reinstalling 3.4.6 the Echos are working again. But the “Trigger Routine” problems remain. On the web interface the already mentioned orange popups come up whenever I hit a key on the keyboard. Here is a screenshot after typing several keys.

@Jamie Seems to work fine for me too with the latest release version. Am using EU Servers.

Hi @Jamie,
I created a flow which notifies me when the server disconnects.
After it happend i created a diagnostic report.
190a7f59-69a8-44fc-a53f-3e016c4eb7fd

Hope it helps
Thank you in advance,
Ron

Hello Community,

I haven’t read about this, so if the question was already asked: sorry for that.

I have multiple Echo devices. Now I have differente use cases where I need several Echo devices to tell me something. E.g. the washing machine finished its job than I want the Echo devices in the bathroom, the livingroom and my office to react and tell me the laundry is done.

But here is my issue: I created three flows. One for each Echo device.
If washing machine is finish, let Echo living room say something
If washing machine is finish, let Echo bath room say something
If washing machine is finish, let Echo office say something
As long as I trigger the Echo device in only one room everything works, but as soon as all three flows have to start nothing happens. I assume, that each flow causes issues on the server of Amazon and no Echo device is reaction anymore to any flow. Is there a workaround for triggering several echos to say something?

Regards
Andreas

correct, to many events put the alexa api in hokd back mode or something.
what i did is:
create a routine in my Alexa App:
name: homey says washmachine done
use the Announce action and tell the message i want to hear then you can select All or several echo devices.

this works perfectly, a bit annoying to create a routine per message, they go in sync

From homey you then use trigger routine to get the message when you want it

1 Like

Thank you Kaoh,

your workaround just…worked :slight_smile:
Great tipp.

Regards
Andreas

Hi, just asking. Is there any news on the “trigger routine” problem? Can I do anything to find the bug?

Hey Sven,

Sorry as far as I can tell it only seems to be effecting you, unless others come forward and I can find some sort of pattern it is near impossible to find the issue.

Sorry


@Kaoh - really nice work around, thank you for sharing, it actually makes me wonder if there is perhaps a whole different way I can go about getting ‘real’ annoucements… ill have to check it out next time. - Thanks

Hey Jamie

I totally understand that. There must be something wrong in my
system. I’ll see what I can do. Thanks for all the good work.

Sven

Jamie Peake via Homey Community Forum writes:

Hi everyone
I have a problem:everyday,i have to restart manually the app because my flows with the option"alexa say" doesn’t work,all my Alexa devices(3 echo dot and 1 echo show8) seems not respond,i click on the device and try an action(weather,traffic,news) but no answer…
i try to create a flow for restart the app every 12 hours but it’s not working,i have to do this manually and then my device works again…anyone have this problem?
I am on the europe server(French),i try the 2 others server but not working…

show your flow please

As far as I can see (I don’t speak France), looks good, sorry no idea why this would not work?

Some one else?