Homey Community Forum

[APP] Philips Hue by Athom

I got big problems with this app now. It just keeps crashing and leaving my homey without only unavailable hue devices?

I tried restarting both the app and homey, but still the same. Anyone have and idea or solution?

After the update of hue, it seems the app looses connection all the time somehow… Anyone else?
It is missing a capability; listening onoff

I got no reason disconnected hue hdmi sync box, after removing and try readd, its not anymore visible to add, restart app, rest connection sync box with hue bridge also not help

hi. is anyone else having issues with the Hue app since upgrading to the latest Homey firmware?

Once a day all my hue bulbs become unresponsive via Homey and i can’t seem to get them back online. I try restarting my router, Homey, the hue bridge and nothing specific seems to work - eventually some combination of these things fixes it but i’m at my wits end as to what going on. The bulbs work fine when controlled via the Hue app during these “downtimes” and my Home Assistant-controlled bulbs all are fine.

Coincidentally, this also coincides with two Wyze cameras being offline during this period. I’m wondering if Homey is somehow gunking up my wifi channel trying to connect to the Hue bridge.

Some times ago i noticed strange effects after an update of the philips hue app in Homey. After turning on lights some lights turned off after a few minutes. Or or it took minutes before they turned on. All happend randomly.
I decided to remove the Philips hue app and build a nodejs service on an old macmini. The same i did in the past with Sonos. That’s working extremely well. Much more flexible.

Yeah, honestly, it’s a bit of a shitshow. Not only are all my Hue bulbs unresponsive but Homey drops in and out of Wifi so it’s impossible to troubleshoot anything. I can’t for the life of me understand why there’s no ethernet port on the thing, if only for stability to the local network.

After futzing around with it for yet another hour today, I could see that the Hue app was taking up over 50MB of Homey’s RAM which doesn’t seem normal. I deleted a few apps that I’m no longer using after having half-migrated to Home Assistant and now things seem to have stabilised a bit. Bulbs are back and Hue app is only using 10-15MB.

I keep meaning to move most of everything over to Home Assistant full (except a few things like the Hyundai homey app which works brilliantly) but it would be a hell of a job, and the MQTT client/hub on Homey made it so easy to pass everything over without having to start from scratch.

I dunno, if this issue with Hue keeps happening I may just bite the bullet and take a day to move everything over.

2 Likes

Great job, I’am planning to do the same. The macmini is 10 years old, but more than capable enough to run Home Assistant.

Since update to 7.15 RC, hue’s response seems to be slower. Many Hue devices connected via Hue bridges. Problem seems to be mainly with switches and restarting the Hue app will fix temporarily.

1 Like

Hi,
does anyone know how to activate automations on the hue bridge? Tried it by webhook flowcard , but not sure what I am doing :crazy_face::face_with_monocle:
Can‘t find them in the clip editor
Thx Thilo

What u wanna achieve with activate an automation?

Put my presense mimiking fron Hue Labs to Automation. Now I want to switch that on and off by Homey, using Geofencing.
I can make a webhook, but I can t find the reference of the automation (using the clip editor)
Thilo

That sounds more like this topic.

Yes, sorry, I was to tumb to copy the link using my mobile…:roll_eyes:
I would like to make an API call as Kevin describes it. But instead using HueLabs I want to use automation. Unfortunatly I dont find the automation nowhere in the Api

The app says it supports the ‘Module’ is that equal to to the Philips Hue wandschakelaarmodule? Just want to know for sure.

Bad experience with hue integration.
I find the hue integration very unreliable. Resulting in lights turned on all night, etc.
Before I controlled the hue lights with node-red for years without problems.
Also when I want to change color and dim-level I have to delay one of them otherwise only one of them comes through. But the delay is very annoying.
With node-red is did send all changes in one message.
Maybe Athom should open source the plugin.

That problem isn’t related to the Hue app, it’s an internal Homey issue: sending commands to multiple devices from a flow will often result in some devices not getting the command. The only solution for that is using delays.

You mean the messages get “lost” in homey, even before sending?
In node-red I did send 7 messages (7 lights) at once to the hue bridge and it always worked.

That’s what it looks like, yes.

Yes, this issue is Homey-specific and it not related, or limited, to Hue.

Did you notice that with other type of devices also?
From the other types I have (mostly Z-Wave, but also some ZigBee), I do not have them in the same flow, so I didn’t notice it and was hoping it was the hue app which then could be improved.

You can try by creating a test flow that uses your different devices, but if you search around the forum you’ll find that it happens for all kinds of devices (Zigbee, Z-Wave, WiFi). Adding delays is how people “solve” this issue.