[APP] NetAtmo by Athom

Yeap, me too.

Netatmo is really giving them a hard time as it seems. :smiley: :smiley:

Now it worked

1 Like

First also An error. After uninstalling app and reinstall it works

1 Like

Yep, I can confirm that deleting the devices and the app and then reinstalling app and devices will work. During install of devices you need to reauthorise homey to access your netatmo data.

Thanks for the fix!

Working here as well :grinning: thanks

Is working here also, thanks!

Hi am i doing something wrong i want to let homey say Hello with the persons name when its recognized. Just got my homey and it’s all a bit new.

Sorry had to place in two posts

Netatmo definitely looks fixed. If only we could put temperature reading on tile itself without the need to long press the tile. :-/

What did you do to get it to work? I receive the same fault message and have now reinstalled the app three times (plus rebooting Homey)

Regards /Niklas

Strange. I did just that, I’ve deleted Netatmo devices, uninstalled the app, reinstalled the app and went trough re-authorization process (added again device, authenticated to netatmo, approved homey app).

Now it worked for me as well but I can’t say why - I just kept trying, waited about 5 min and then tried again. Now it worked without a fault message. hmm

Can you get a notification in a flow to work? Nothing happens in my “Human detected -> send a mobile message” Flow (but works via Netatmo app)


I’m getting an error “cannot convert undefined or null to object” after authorising Athom to manage my netatmo devices.
I’m not able to add my device.

I’ve tried to relaunch the app, and to reinstall it as well…

any help.?


Any one who have a clue why I get insights on all my weather station devices (outdoor, rain, wind, extra indoor) but NOT from the main station itself? (It is reporting - I can see that from my NetAtmo webpage/app)

Edit: Restarting NetAtmo app did not do the trick. Removing and re-adding the device did, though.

Solved (for this time at least)


any updates in when netatmo valves might be supported (controlling temperature settings). Or is the way forward to post it as an issue since it is listed under “supported devices”. Sounds like no one has managed to get them to work properly…

Without reporting an issue it will never be resolved… Athom does not track this forum, so definitely report an issue.

Just did, thank you :blush:

1 Like

You mean the valves that are already in the app?

Correct, by looking at picture showing supported devices, the valves are show. But looking in the textual list of supported devices, it’s not. And looking in forums about the valves it looks like temperature control is not supported through the homey app (but supported through vendor specific bridge with their own app). I might be out in the blue here, but don’t want to invest in the valves if I’m not certain that they are fully compliant. And I can’t see any statement which prooves the fact.

Somebody knows anything about my issue dat i post earlier ?