[APP] NetAtmo by Athom

Sounds great edwinw. Can’t wait to get support for valves. Appreciate your efforts!

@akafester and @Morten the latest Netatmo app 4.0.0 supporting now the valves :grinning:
I don’t own any to test. I will buy some for sure before next winter (full summer here now :beach_umbrella:

@danone Yeah i got a notification from my homey about it.
It seems to be working as expected and will, of course, report back if there are any issues.

And thanks for the heads up :slight_smile:

Hi I will test tomorrow and give you some feedback. Thanks for now. Reverting.

Med venlig hilsen ¦ Best Regards,

Morten Steen Søndergaard

Just as I was about to look into this, it appears someone at Netatmo already picked this up :slight_smile:

Unfortunately not able to test it myself, as it requires an update to 2.0…

Hi. Trying to install app version 4.0.2 on Homey but I get error that “app is incompatible with your Homey software version”.My Homey is running version 1.5.13. Do I need to upgrade to non public version?

Thanks,

Morten

This app version only works with firmware 2.0.
So yes, you need to upgrade if you want to use Netatmo 402.
Just be aware that firmware 2.0 is still a work in progress. Plenty of talk about it here on the forum.

Has anyone tested the function to get/send a picture of the Presence camera?

I tried the following, but it doesn’t work

I get a push notification, but without a picture!

Klingel2

Can anyone with a Presence camera double check this?
If I am not the only one with that problem, I will report an issue.

@Bram Just wanted to mention also here that in NetAtmo after the upgrade to 2.0 it’s currently impossible to add the Weather station. After the authentication is passed and permissions were given to the Homey lower is displayed.

meme message , homey 2.0 …

In case someone else has the same issue, Bram confirmed they are working on a fix. We’ll just have to be patient then.

After my upgrade to 2.0, none of my Netatmo device worked. Restarting the app didn’t help, removing and re-authorising gives the notification ‘token refresh failed’…? App version is 4.0.5, is there something I’m doing wrong?

So…… and what if you read the response above yours :woozy_face:

Please file a bugreport at https://support.athom.com/hc/nl/requests/new and be as extensive as possible. or send a mail to support@athom.com

I have read that, but since the error message was (is) different, I thought it would be helpful to mention it anyway.

Will do!

With 4.0.4 error was req is not defined. Then 4.0.5 came out, first error was resolved but another one came (token refresh). Hopefully tomorrow we will have all back to normal.

Having exactly the same issue.

Version 4.0.6 released.

Now I have:

Error: token refresh failed, an additional error with an different try:
Error: Application usage reached (Code 403)

Yesterday I always got the “Token refresh failed” error

Today with 4.0.6 i get the “Application usage reached (Code 403)” error