[App] Fibaro by Athom

I got the green success bar when saving. I woke the device both before and after saving by activating the tamper alarm



Fibaro usually lists its devices as multi node device even if they are not. So setting the id to 46.1 may do the trick.

And another thing, if saving didn’t work the first time, the settings may list the association even when it is not actually set - and it won’t save it either in latter attempts. Changing it and saving it to something else and then saving the right one may also help.

1 Like

Amazing! That seems to have done the trick!!

Now a follow up question… Is there any way to make this “lock” so that if the flood sensor alerts the plug switches on, but doesn’t switch off until manual intervention?

I know I can do this in Homey itself but would prefer to get this via association, and if it stops the moment the the alarm stops then my flood is going to keep happening!

I do not have much experience with associations with anything else but buttons, but usually the associations are pretty straightforward. They are not meant to be as smart as Homey. Also the socket does not really know what turned it on or off, so I think there’s no other way then to use Homey for the extras logic.

Homey does see what the associations have done, so there’s nothing from keeping you to add extra logic to the mix. So if you see the flood sensor arms and turns on the socket you can have additional logic to immediately turn the socket back on if some one or some thing tries to turn it off.

Yeah, I understand that, but with a flood sensor, you would assume that it would force the plug to on and stay on given the main use case

How do I get Homey to act on just the association switch rather than a manual switch?

Well, just listen to the flood sensor alarm? Or: something like:
if socket is turned off and flood sensor alarm is on turn socket on.

Remember, the flood sensor probably cannot see the socket turns off, let alone know that isn’t what you want. And the socket does not know it should check the flood alarm is still on.

The association does that, if the alarm is on socket is on (which is what I want)
But in the use case (to detect floods and activate a solenoid shut off) the water could plausibly drain away, meaning then the alarm goes off but the problem still remains, so re-causing the flood and additional damage
I need the socket to only shut off with manual intervention

Yes, I understand and your use case is valid. But you cannot create such complicated scenario’s using associations alone. They are simple trigger → action commands without any logic to guide it.

You could have the flood alarm enable the flow that will block any other things, and the intervention will then be to disable the flow again. Or you could make use if a variable signalling the system is in normal or blocked mode.

Thx @Edwin_D for helping out!

Just for info, there are two different green bars when saving.

  1. Settings were saved
  2. The settings will be saved at the next wakeup of the device. (Approx. wording)

In the second case the changed settings are not saved yet, even if the changed settings are already shown in the advanced device settings. (Mentioned already by Edwin)

This isn’t useful.

The firmware of the sensor is 3.3:

Btw, the WakeUp method depends also on the firmware!

Is this information based on practical experience? Or is it just a guess?
If it is a guess, why not just try out the function?

No, this is after the test. It turns off when the water goes.

Ok, a possible workaround is to use a flow:

– The water alarm turned off
– Turn on WP with 3 s delay

The delay is used to ensure that the plug was definitely switched off first by the association and can then be switched on again a few seconds later. This is to prevent the “Off” and the “On” command from being sent at the same time.

Oddly, I’ve just tested this again and it’s now no longer working… has anything changed in the past 10days that might have caused the association to break?

EDIT: Just set up a second flood sensor and that now works with 46 association (not 46.1). So changed the other one back to 46 and still nothing… very odd

EDIT2: Okay, after changing and resaving a few times this seems to be working with 46, not 46.1 (which is what made it work before)… wonder if a recent update changed this somehow

Now I have a slightly different issue related to the flows.
Per discussion above I made a flow to turn the plug back on if it is turned off (basically forcing it to stay on if activated), with an override flow for manual intervention. Figured this was marginally more robust that @fantross suggestion of using the water alarm, as I don’t need to wait for the delay)

The problem I now have is that it doesnt seem to work with the association driven input. It works absolutely fine if I run a flow which tries to turn it on / off, and even works if I use the physical button to try and turn it off, but if it is turned off by the association turning it off when the water is removed… nothing
Any ideas?

Maybe the flows and the associations interfere with each other?
Have you deactivated the flows and then checked if the WallPlug is switched on and off again by the association?

Flows were disabled for turning off :disappointed:
Association was kicking in as expected, but seems it doesn’t report it’s action to homey

after update to 3.1.5 my roller shutter 3 is not working anymore for all my screens

Here no issues at all. Try restarting the Fibaro app.

here in the dutch section some more people who have the same problem

But did you restart Homey and the Fibaro app?

If that doesn’t work, reinclude them with S2 00000 code.

I successfully re-added 5 out of 6 roller shutters (RS3), for some reason one of them is refusing to pair…I tried to unplug it reset it, even “any node removal” and still nothing (just blinking green followed by red after aprox. 2 min. Any9ne experienced something like that?

update removed last added node and then I was able to add both after all…seems there was some problem with ZWave chip itself