[APP][Cloud & Pro] SwitchBot (Release 1.1.22)

The curtain motor is larger, so maybe it has a better antenna. Could you enable the log and send it to me after some failures so I can see if it shows any errors?

I’ll try putting it in the same room.

Another issue now. App has crashed twice in maybe 14 hours now. Had to restart app to get bot to work

Me too Radon, heard it aswell on the homey Facebook page

Diagnostic report :

After repairing or restarting the app, it works fine again.

1 Like

Should all be fixed in the latest version.

Thanks Adrian, ur a star. I thought I had the latest version already. Just installed the test version. Hope it’s fixed :ok_hand:

Installed the test version (1.1.20) and added my Switchbot Tilt. I’ve experimented a bit with the device and I can control my Tilt from Homey. However there are a few issues when I’ve done so:

  • When I want my Tilt to close up, it closed down. And when I want my Tilt to close down, it closes up. Strangely enough it does display the correct position of the Tilt. So from what I can see the display of the position works correct, but the controls are inverted.
  • When I use the device in Homey to fully close up, the app gives: “Error: an unknown code (400) returned by Switchbot”. And then it does nothing.
  • Changing the position a few times while it is still busy returns a 200 error (inconsistently, and I lost connection to My Homey when doing this so I’m not eager to repeat this)

Also I have the following suggestions:

  • Add Flow cards so I can control my Tilt using Flows. I can use scenes for now, but using a device has my preference.
  • Right now it is just a slider. It would be nice if there was a way to select/switch between fully open, closed down and closed up (maybe have the slider stick to those positions while still allowing positions in between?)
  • Adding a battery monitor would also be very handy (so Homey can give me a message when the device needs charging).

Thank you for your effort and I hope the feedback above helps. I’ve also made a diagnostics report from the app and send you the code. If you need any (further) help, I’m happy to assist.

This is why I like to have the device so I can test things :wink:
I will invert the position control.
I will investigate the errors.
The flow cards should be there as I have used a built in capability.
In theory taping on the top of the slider should fully close up and taping on the bottom should fully close down.
The API doesn’t provide any battery information so I can’t add that. I have been asking Switchbot to provide battery information for all their devices via the API for a long time but it falls on deaf ears.

Unfortunate for the battery, but it is what it is. In the API response there was a battery field, but it doesn’t match the value in the Switchbot app, so no battery.
Maybe an extra button to fully open up the Tilt, that would be very handy (for quickly switching from closed to open and vice versa).
Unfortunately I don’t see any Flow cards, so there might be an issue with the built in capability for those.

I hope that Switchbot gives you a device for testing & developing.

I have published a test update.
This reverses the position commands, adds flow cards and should fix the error (except the 200 error as nothing I can do about that).
Loosing connection to Homey is not uncommon and is not related to the 200 error. Both my Homeys loose connection at times and my development one has nothing running on it most of the time. The connection should recover after a few minutes when Homey next calls home.

Switching between fully closed Up or Down is just a case of taping on the icons at the end of the slider, so those buttons are already there. The fully open is a little less accurate, but it is just a case of taping on the centre of the slider. Adding more buttons is against Athom’s interface guidelines so would make it more difficult to pass the submission process.

I’ve done some testing:

  • the 400 error is still there when fully closing down (both the button as well as the slider give that error). Same behavior if I use the flow card to set it to 0%.
  • When the tilt is changing positions, the slider jumps back. Also the tilt changed flow trigger reports multiple times when it is moving. Looks like the update happens when the tilt is still in motion. Which might be an issue when using the flow card and is a bit annoying/confusing when using the slider (since it is for both control and display).

Can you set the log level to Basic and then send me the logs again after moving and getting the error.

Also, could you set the log level to Webhook Information, move the blind and then send the log.

Which KPN receiver do you have, @Paul_Kuiper?

I am looking for a way to control my 4K set-top box (=Arris VIP5202)

And does the Switchbox Hub send it"s commands via BLE or IR?

Done and done. Also send you a log with full information after moving the tilt.

If you need any further information, please let me know.

I have changed the command for 0 and 1 to use the ‘closeDown’ and ‘closeUp’ commands.
I have also trapped the values between 0.4 and 0.6 to send the ‘fullyOpen’ command which should make it easier to tap in the middle of the slider to fully open the blinds.

Let me know what you think.

Hoi Henk,

ik heb zowel de Arris VIP2952 V2 welke net als alle niet 4K werkt via IR en de nieuwe 4K (Arris VIP5202) welke via BT werkt.
De SwitchBot Hub werkt via WiFi met de Homey Pro 2019 en via zijn IR met de IR devices.
Ik kreeg Homey niet werkend met de IR en de IR van de 2019 is ook niet zo sterk begreep ik.

Nu wacht ik op de Homey Pro 2023, welek veel sterker, sneller en zo is en een LAN via USB-C heeft.
Want ik heb steeds meer problemen met mijn 64 Zigbee devices.

Enhglisch version:

I have both the Arris VIP2952 V2 witch works ike all the non 4k with IR and I have a new 4k (Arris VIP5202) wich works wit BT.
My SwitchBot work trough WiFi with Homey Pro 2019 en trough it’s IR with my IR devices.
I coudn’t get my Homeys IR working.

Currently I’m waiting for my new Homey Pro 2023 wirh LAN trough USB-C to get my Zigbee network stable again, 64 Zigbee devices seems to be to much…

Can you please keep it in English?

From what I have tested, this works. Great job, thank you very much!

1 Like

Hi Adrian, @Adrian_Rockall
First of all great job and thank you for making this app.
I just got my Switchbot Tilt Blind.
It is my first Switchbot device and I’m reading the small letters now.
I did not know Switchbot devices needed a hub to connect them to the internet.
I saw the Curtains have a BLE option.

Are you planning to release also a Tilt/Blind BLE option? If not I’m going to buy a hub.
Other wise i will buy you a bear :wink:


As the Tilt is new, and I haven’t got one, I haven’t had a chance to decode the Bluetooth information. To be honest, Homey BLE is not very good, so I would recommend getting a Switchbot hub anyway.

I will add the BLE device as soon as I can though.

I have the last 2 days problems with the homey app of switchbot.
My curtains react very slow (connected via BLE) sometimes they don’t react, when i use the scene option (via hub) then nothing happens.
When i use the switchbot app on my phone or homeassistant (ble) then the motor respond immidiatly.
No often the curtains do not open at all in the morning (i use scene card of switchbot hub) or close in the evening, manually via homey (via ble) i get network a network error in homey.

I also noticed that when the curtain moves the position in homey is not updated or takes very long time to do so.
Also message such as failed: previous message stil sending (or something like that)

Until 2 days ago i had nog issues.

I run the latest test version of your app and send in a test report with id: 4fb81cc2-82f4-473b-be7a-837ceeffb95d