[APP][Cloud & Pro] Somfy Tahoma & Connexoon (v4.0.13, test v4.0.22)

Hi Adrian,

I have 2 Atlantic hot water production heatpumps (Calypso VM), I tried to connect them via the Tahoma hub and the Tahoma Switch. Can you guide me how to connect these, what hub is supporting the combination with your app.

Thanks in advance!

Cheers Nick

Do you see the heat pumps in the Somfy app?
If you do then send the device log from the Configure App page so I can check the information.

Hi @Julius_1977, I’m the new developer of the Homey MELCloud app.

Unfortunately it’s not possible to port my app to Homey Cloud.

To develop apps to be run on Homey Cloud, you need to belong to the company brand developing the official app, or be commissioned by it – what is not my case. You’ll find details here: Homey Cloud - Homey Apps SDK Sorry… Regards

Hi. Will it be possible to support the IntelliTAG sensors?

thank you
Angelo

If you have them paired with Tahoma then send me the Device log from the Homey Configure App screen and I will see if they are reported.

I wanted to change the polling rate… but I can’t find the seting anywhere.

Similarly, I can’t find a flowcard which can change this.
I do have flows which enable or disable polling alltogether… but from what I can tell, these flowcards are no longer available, aka: these became legacy?

@Adrian_Rockall Is it correct that polling (frequency and such) is now all handled by the app itself?

Correct, the app decides on the polling rate required for optimum performance, while keeping within the allowed limits.
For Cloud connections the rate is once every 30 seconds and for local connections it is once every 3 seconds.
The new polling method only requests changes that have occurred since the last request, so most of the time only and acknowledgement is returned.

1 Like

This morning there were some errors regarding “far too many login attempts”. (thus my question regarding polling)

Sadly, it happened again.
I also tried sending the log, but for some reason that ended up in an error (and also got logged).

I copied the tail of the log:

  {
    "time": "2022-12-23T17:01:21.474Z",
    "elapsed": 0.145,
    "source": "Register Events",
    "data": "Far Too many login attempts (blocked for 15 minutes)"
  },
  {
    "time": "2022-12-23T17:07:54.752Z",
    "elapsed": 393.278,
    "source": "Send log error",
    "data": {
      "message": "[object Object]",
      "stack": "Error: [object Object]
                at SMTPConnection._formatError (/node_modules/nodemailer/lib/smtp-connection/index.js:790:19)
                at SMTPConnection._onError (/node_modules/nodemailer/lib/smtp-connection/index.js:776:20)
                at Immediate.<anonymous> (/node_modules/nodemailer/lib/smtp-connection/index.js:301:52)
                at processImmediate (node:internal/timers:466:21)"
    }
  }
]

@Adrian_Rockall Is there anything I can do to alleviate my amount of api calls/login calls?

Any tips are appreciated, thanks in advance!

The login attempts is different to the polling rate. Once the app is logged in it keeps the connection alive by polling for events.
The error you see means the login failed so the app backs off before it is blacklisted. This is normally caused by either a bad Internet connection or a glitch on their servers.
If you can switch on the local connection via the Somfy web app then you should find it a lot better.
When using the Internet access, the token has to be refreshed once an our, but the local access token shouldn’t expire.

Switch to local connection? That does not ring a bell.
Is that a specific URL (that I am unaware of)?

I looked at the usual places, but couldn’t find it.
Though I did find out that there was an update available (so, atleast I did that).

It also might be something Somfy doesn’t support for the Connexoon box.

Ah, correct, not available on Connexoon yet. I believe it is on their list.

1 Like

I have a Velux skylight shutter io. Is it possible to control it using this app with this control box → Somfy Connectivity kit 1870755 ?

I believe so. I don’t have either myself but the app supports the connectivity kit and Velux shutters so i can’t see why there would be any problems.

Hello, I am new to this forum and I would like to ask if it is possible to connect the Somfy Situo 5 io Pure II and Situo 5 RTS Pure II controllers to Homey. Thank you for your response.

They definitely can’t be connected directly.
I’m not sure if they can be added to Tahoma as my RTS remotes only pair with the motors.
However, some users must have added remotes because they have sent me logs so I can add support for them to Homey. What I don’t know is which remotes they are.

Thank you for the quick reply. It would be possible to somehow connect the motors to the Homey, or there would have to be a Somfy control unit.

If the motors use the RTS technology then you can use the Somfy RTS app for direct control.
If the motors use IO technology then you will need one of the Somfy bridges, such as Tahoma, Connexoon or the Connectivity Kit. Then you can use this Somfy Tahoma & Connexoon app. Of the three choices, the Connectivity Kit is the cheapest option and Tahoma is the most expensive. As you can also add RTS devices to some of the Somfy bridges, you could also use this app for the RTS devices via the bridge.

Hi Adrian, and first of all, thank you very much for the work you are doing on this app.
Is there any chance to add the towel dryers from Atlantic ? They are working with the io protocol.
It works with a cozy bridge.
Here is a link to the specification : https://www.atlantic.fr/gaatlanticerp/download/serenis-premium-notice-installation-utilisation-atlanticpdf

I’m not familiar with the cozy bridge so is that accessible via Somfy login?
Have you got the app installed already and can you login?
If so can you send me the device log from the Configure App screen.

Sorry, it is called Cozytouch not cozy bridge. There is a io logo on the Cozytouch and on my towel dryers but I can’t find any way to add them neither on the somfy app on my somfy box nor on homey. As it is using the io protocol, I am a bit lost and I don’t understand why it is not working. Maybe the job must be done on somfy and Atlantic at first ?