[APP][Cloud & Pro] Somfy Tahoma & Connexoon (v4.0.13, test v4.0.22)

I’ve just noticed that i’m already getting the 3000ms timeout while entering my credentials.
When proceeding it seems to validate the credentials resulting in just " error". The logs remain empty.

Could you update to the test version by adding test to the end of the URL for the app in the store.

Thanks for the support Adrian (it most be a full time job on the side),

After restarting my homey for the 3rd time i was able to login. (using 3.0.35)

1 Like

I’m about to get the Atlantic Fujitsu Alfea Extensa heatpump with Atlantic Fujitsu Cozytouch Bridge. From the devices search I understand that I can connect that via this App. However it as asking for a Somfy login. Is anybody famiiar how I can connect them or how this works?

Is seems that Cozytouch can use the Somfy IO protocol. from the FAQ

To pair the IO devices, how can I connect the Cozytouch bridge?
The bridge has to be connected to a power supply (using the USB cable or plug adapter) and to be connected to the internet box through the ethernet cable (RJ45).

If I cannot control this brand with Homey I will consider another brand/setup.

@Ben_Proquin you also asked about this, did you get it working?

This app only works if you have a Somfy account with one of the Somfy hubs (Tahoma, Connexoon, etc). I’m not sure how other users have connected their Atlanta devices but my guess is they use a Tahoma hub.
Maybe someone that his done this can confirm?

1 Like

Hi Adrian,
Thanks for creating this app. I have a Somfy Tahoma that has been successfully included to Homey. I have four Somfy IO external window blinds connected to the tahoma hub, that I currently control through the Tahoma app or by a Situa 5 remote.
However, when trying to add the external IO blinds to Homey I get the message that “No new devices have been found”. I have tried several times over the last few days, restarted Homey and downloaded both the beta version of the app and the latest published version.
I have just sent the device log through the app.
Am I doing something wrong?

Hello Adrian

Have you a chance to take a look at it :grinning:

Have a nice weekend

Sorry I can’t remember :grin:
Thanks for reminding me, I will look this evening.

I think I have your log so will take a look.

I can see the card’s in my Homey so it seems I have done it. Could you try the test version to see if I have published it?

I have cheked and install test version and device again. But I still cannot see action card on the I/O heating wire pilot controler.

Ok, I will check that one.

The log I am looking at has the following device names: “TV-stue”, “Kjøkken”, “Kontor”, eyc so if that is correct then it looks like you can add your blinds using the “Awning / Pergola (io)” / “Buitenzonwering / Pergola (io)”. I know it’s confusing but the app works on the internal “controllableName” provided by Somfy and integrators are starting to repurpose the motors for other types of covers.

I have published a new test version. Hopefully I have the right device this time :slight_smile:

Thank you for your effort unfortunatly no changes. New versions was installed on my Homey, I have restart it and reinstalled the device but still no cards. Only possible to control them in manual but not in a flow. You could find in attached some screenshot.

OK, I keep picking the wrong device, so back to the drawing board.
Could you send the device log from the Configure App screen so I can see what devices you have and then hopefully I will get the correct ones. They should all support the flows, but as there are over 100 different devices, it can take a long time to track them down.

No problems, I just send you the log device and errors

OK, new version. Hopefully I got the correct device this time.

It’s working perfectly thank you very much :grinning:

How can I give you something for your work, I don’t see any button to send you something.

That’s good, I got there eventually :slight_smile:

Athom don’t publish the contribute button for verified developers. My username on PayPal is adyrock but don’t worry if you haven’t got access to that as I create the apps for fun.